diff mbox series

[bug#70855,01/92] gnu: python-seaborn: Correct dependencies.

Message ID 20240509225530.24649-1-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-seaborn): Correct dependencies.
  [propagated-inputs]: Move python-ipykernel, python-mypy,
  python-nbconvert, python-numpydoc, python-pyyaml from here...
  [native-inputs]: ... to here.

Change-Id: I94a28f0cb8ec7c2171007f2b635dc10d7a8fcc8c
---
 gnu/packages/python-xyz.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6fbc6f55591..c1590c2b568 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13834,22 +13834,22 @@  (define-public python-seaborn
                 "0ycibcs6kvd3xi4zsxna81claqifyb9dn6z6jwc5x7lqqplnbbdz"))))
     (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-ipykernel
-           python-matplotlib
-           python-mypy
-           python-nbconvert
+     (list python-matplotlib
            python-numpy
-           python-numpydoc
            python-pandas
-           python-pyyaml
            python-scipy
            python-statsmodels))
     (native-inputs
      (list python-flake8
            python-flit-core
+           python-ipykernel
+           python-nbconvert
+           python-numpydoc
+           python-mypy
            python-pytest
            python-pytest-cov
-           python-pytest-xdist))
+           python-pytest-xdist
+           python-pyyaml))
     (home-page "https://seaborn.pydata.org/")
     (synopsis "Statistical data visualization")
     (description