diff mbox series

[bug#70855,03/92] gnu: python-black: Move to pyproject-build-system.

Message ID 20240509225530.24649-3-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-black): Improve package style.
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Improve style of use-absolute-file-names
  phase. Remove phase check.

Change-Id: If2da4b3b0fea4928d1aeb270fbaa4167f20a6ee5
---
 gnu/packages/python-xyz.scm | 18 ++++++------------
 1 file changed, 6 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c1590c2b568..862efc0f5b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8262,22 +8262,16 @@  (define-public python-black
        (sha256
         (base32
          "0yfahlqc7dsdp1js0cbv706apldnfnlbal9b53cww8n0hs40n0im"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'patch-source-shebangs 'use-absolute-file-names
-           (lambda* (#:key native-inputs inputs #:allow-other-keys)
-             (let* ((inpts (or native-inputs inputs))
-                    (python3 (search-input-file inpts "/bin/python3")))
-               (substitute* (find-files "tests" "\\.py$")
-                 (("#!/usr/bin/env python3(\\.[0-9]+)?" _ minor-version)
-                  (string-append "#!" python3 (if (string? minor-version)
-                                                  minor-version
-                                                  "")))))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests? (invoke "pytest" "-vv")))))))
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* (find-files "tests" "\\.py$")
+               (("#!/usr/bin/env python3")
+                (string-append
+                 "#!" (search-input-file inputs "/bin/python3")))))))))
     (propagated-inputs
      (list python-click
            python-attrs