diff mbox series

[bug#70855,66/92] gnu: python-shtab: Move to pyproject-build-system.

Message ID 20240509225530.24649-66-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-shtab):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove uneeded field.

Change-Id: Ie27661677e88c5743423946d13bbe07a2c51bf36
---
 gnu/packages/python-xyz.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b21bb7e862d..5a12dacbc8c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35612,7 +35612,7 @@  (define-public python-shtab
         (uri (pypi-uri "shtab" version))
         (sha256
           (base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (native-inputs
       (list bash
             python-pytest
@@ -35620,15 +35620,6 @@  (define-public python-shtab
             python-pytest-timeout
             python-setuptools-scm
             python-wheel))
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace
-             'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest")))))))
     (home-page "https://github.com/iterative/shtab")
     (synopsis "Automagic shell tab completion for Python CLI applications")
     (description