diff mbox series

[bug#70855,04/92] gnu: python-isort: Move to pyproject-build-system.

Message ID 20240509225530.24649-4-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:52 p.m. UTC
* gnu/packages/python-xyz.scm (python-isort):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Add option to replace former check phase.
  <#:phases>: Remove phases build, install and check.

Change-Id: Idac8f151977f2494eb44d51aa1fcbf3156b5cc87
---
 gnu/packages/python-xyz.scm | 22 ++++------------------
 1 file changed, 4 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 862efc0f5b5..c4b37270668 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24322,19 +24322,13 @@  (define-public python-isort
        (sha256
         (base32
          "1vbwc4gpffclf6hw08lvvgqlvsgfjlw7gjsm28jfcrln2pixla7j"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "tests/unit/" "-k" "not test_gitignore"
+                          "--ignore=tests/unit/test_deprecated_finders.py")
       #:phases
       #~(modify-phases %standard-phases
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl))))
           (add-after 'install 'install-example-plugins
             (lambda _
               (for-each (lambda (source-directory)
@@ -24348,15 +24342,7 @@  (define-public python-isort
               (setenv "HOME" (getcwd))
               (let ((example-whls (find-files "dist" "^example.*\\.whl$")))
                 (apply invoke "pip" "--no-cache-dir" "--no-input"
-                       "install"  "--user" "--no-deps" example-whls))))
-          (replace 'check
-            (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-              (when tests?
-                (let ((bin (string-append #$output "/bin")))
-                  (setenv "PATH" (string-append (getenv "PATH") ":" bin)))
-                (invoke "pytest" "-vv" "tests/unit/"
-                        "-k" "not test_gitignore" ;requires git
-                        "--ignore=tests/unit/test_deprecated_finders.py")))))))
+                       "install"  "--user" "--no-deps" example-whls)))))))
     (native-inputs
      (list python-black
            python-colorama