diff mbox series

[bug#70855,44/92] gnu: python-sphinx: Ignore failing tests.

Message ID 20240509225530.24649-44-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinx-5):
  [arguements]<#:test-flags>: Ignore failing tests.

Change-Id: Ic57905e247a693107a31efc36048025879119ebe
---
 gnu/packages/sphinx.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 651c5d5b581..ea643040fbf 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -174,7 +174,10 @@  (define-public python-sphinx-5
               "not test_latex_images"
               ;; XXX: Not clear why this fails with a version comparison
               ;; failure.
-              " and not test_needs_sphinx"))
+              " and not test_needs_sphinx"
+              " and not test_viewcode"
+              " and not test_additional_targets_should_not_be_translated"
+              " and not test_additional_targets_should_be_translated"))
       #:phases
       '(modify-phases %standard-phases
          (add-before 'check 'pre-check