diff mbox series

[bug#70855,39/92] gnu: python-cucumber-tag-expressions: Move to pyproject-build-system.

Message ID 20240509225530.24649-39-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-check.scm (python-cucumber-tag-expressions):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove uneeded field.

Change-Id: Ibf0d92aa761f7a00f8c2c806a8bbd38669987ad7
---
 gnu/packages/python-check.scm | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 8e2164a82db..a3eecba5495 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -262,16 +262,7 @@  (define-public python-cucumber-tag-expressions
        (uri (pypi-uri "cucumber-tag-expressions" version))
        (sha256
         (base32 "0q7rn4l4ppjd1zsglr37ccc5xccg4iigaw827282zfzfsvzda573"))))
-    (build-system python-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (replace 'check
-                 (lambda* (#:key tests? #:allow-other-keys)
-                   (when tests?
-                     ;; Ignore the configuration file since we don't
-                     ;; need HTML reports, etc.
-                     (invoke "pytest" "-c" "/dev/null" "-vv")))))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-invoke python-pathpy python-pytest))
     (home-page "https://github.com/cucumber/tag-expressions-python")