diff mbox series

[bug#70855,52/92] gnu: python-docspec-python: Move to pyproject-build-system.

Message ID 20240509225530.24649-52-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-docspec-python):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Remove uneeded field.

Change-Id: Ib728c442a130eecebe4dff1e364d997bcca76076
---
 gnu/packages/python-xyz.scm | 12 ++----------
 1 file changed, 2 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index facad6c8689..323bbfc1b4d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -812,16 +812,8 @@  (define-public python-docspec-python
         (base32 "0n8m52vxmlvkj7p5jmd4rfdks65rrp4q4vzak44y6kbg9l5qa6y4"))))
     (build-system pyproject-build-system)
     (arguments
-     (list
-      #:tests? #false  ;there are none
-      #:phases
-      '(modify-phases %standard-phases
-         (add-after 'unpack 'relax-requirements
-           (lambda _
-             ;; We don't have black 23.
-             (substitute* "pyproject.toml"
-               (("23.1.0") "22.3.0")))))))
-    (propagated-inputs (list python-black python-docspec python-nr-util))
+     (list #:tests? #false))  ;there are none
+    (propagated-inputs (list python-docspec python-nr-util))
     (native-inputs (list python-poetry-core))
     (home-page "https://github.com/NiklasRosenstein/docspec/")
     (synopsis "Produce docspec data from Python source code")