diff mbox series

[bug#70855,76/92] gnu: python-zope-i18nmessageid: Move to pyproject-build-system.

Message ID 20240509225530.24649-76-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-web.scm (python-zope-i18nmessageid):
  [build-system]: Move to pyproject-build-system.
  [native-inputs]: Add python-setuptools and python-wheel.

Change-Id: Ia9e142a53721bb6d7495d87b59d5f4f3b3f77bf2
---
 gnu/packages/python-web.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4d3fc75bb3c..c24a3daa2e1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3123,9 +3123,10 @@  (define-public python-zope-i18nmessageid
        (uri (pypi-uri "zope.i18nmessageid" version))
        (sha256
         (base32 "14mx62khys82p2gmmf3m40x4jmvcz3rndvl6qik2n2qfp13n7ds7"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-coverage python-zope-testrunner))
+     (list python-coverage python-setuptools
+           python-wheel python-zope-testrunner))
     (propagated-inputs
      (list python-six))
     (home-page "https://pypi.org/project/zope.i18nmessageid/")