diff mbox series

[bug#70855,83/92] gnu: python-numpydoc: Move to pyproject-build-sytem.

Message ID 20240509225530.24649-83-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-numpydoc):
  [build-system]: Move to pyproject-build-sytem.
  [arguments]: Move <#:phases> check replacement to
  <#:test-flags>.

Change-Id: Ia7a812c4ee2adcd31fc32db1caa7c163cadf46bf
---
 gnu/packages/python-xyz.scm | 14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 61a517f72a6..5ec54c839b1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9182,16 +9182,12 @@  (define-public python-numpydoc
        (sha256
         (base32
          "0k2z3g4s3w39h1nd293542hl9qv55j29gcr3bkia0rr3ldsppnxh"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "pytest" "-v" "numpydoc/tests"
-                       ;; TODO: unclear why these fail.
-                       "-k" "not test_MyClass and not test_my_function")))))))
+     (list #:test-flags
+           '(list "numpydoc/tests"
+                  ;; TODO: unclear why these fail.
+                  "-k" "not test_MyClass and not test_my_function")))
     (propagated-inputs (list python-jinja2 python-sphinx))
     (native-inputs (list python-matplotlib python-pytest python-pytest-cov))
     (home-page "https://pypi.org/project/numpydoc/")