diff mbox series

[bug#70855,54/92] gnu: python-jaraco-context: Move to pyproject-build-system.

Message ID 20240509225530.24649-54-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm:
  (python-jaraco-context)[build-system]: Move to pyproject-build-system.
  (python-jaraco)[arguments]: Convert <#:phases> to <#:test-flags>.

Change-Id: Ifc9b8fc4a9a6c1c2f37fd014eeee1205cd2eb2c4
---
 gnu/packages/python-xyz.scm | 13 ++++---------
 1 file changed, 4 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32991d57a1f..654224ee17e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11818,7 +11818,7 @@  (define-public python-jaraco-context-bootstrap
         (uri (pypi-uri "jaraco.context" version))
         (sha256
          (base32 "0hbjm1rpxf4pzmbdp9rh3ali4zqnlcr8m97bhh1nizxvzcpxim7h"))))
-     (build-system python-build-system)
+     (build-system pyproject-build-system)
      (arguments (list #:tests? #f))
      (native-inputs (list python-setuptools-scm))
      (home-page "https://github.com/jaraco/jaraco.context")
@@ -11835,14 +11835,9 @@  (define-public python-jaraco-context
          (package-arguments python-jaraco-context-bootstrap)
        ((#:tests? _ #f)
         (not (%current-target-system)))
-       ((#:phases phases #~%standard-phases)
-        #~(modify-phases #$phases
-            (replace 'check
-              (lambda* (#:key tests? #:allow-other-keys)
-                (when tests?
-                  ;; Do not test the myproject.toml build as it tries to pull
-                  ;; dependencies from the Internet.
-                  (invoke "pytest" "-vv" "-k" "not project"))))))))
+       ;; Do not test the myproject.toml build as it pulls dependencies.
+       ((#:test-flags test-flags '())
+        '(list "-k" "not project"))))
     (native-inputs
      (modify-inputs
          (package-native-inputs python-jaraco-context-bootstrap)