diff mbox series

[bug#70855,19/92] gnu: python-apiron: Move to pyproject-build-system.

Message ID 20240509225530.24649-19-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-web.scm (python-apiron):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Replace field with <#:test-flags>.

Change-Id: I04bb9739b6356fd50fc07ae54838764d51ed22d6
---
 gnu/packages/python-web.scm | 11 ++---------
 1 file changed, 2 insertions(+), 9 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 73f26bb9528..fd9d49e2e2f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3554,16 +3554,9 @@  (define-public python-apiron
        (uri (pypi-uri "apiron" version))
        (sha256
         (base32 "1qwbqn47sf0aqznj1snbv37v8ijx476qqkjf5l9pac7xjkxsr8qk"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "--cov" "-k"
-                     ;; This test tries to connect to the internet.
-                     "not test_call"))))))
+     (list #:test-flags '(list "-k" "not test_call")))
     (propagated-inputs
      (list python-requests))
     (native-inputs