diff mbox series

[bug#70855,14/92] gnu: Add ghc-language-python.

Message ID 20240509225530.24649-14-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-language-python): New variable.

Change-Id: I29bcdedf155486673e01b3b6af71a2aa81455ef6
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b5943f2f476..23af2a03bde 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6397,6 +6397,31 @@  (define-public ghc-language-haskell-extract
 with @code{wc} (for a web service).")
     (license license:bsd-3)))
 
+(define-public ghc-language-python
+  (package
+    (name "ghc-language-python")
+    (version "0.5.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "language-python" version))
+       (sha256
+        (base32 "1mf3czvnh9582klv0c9g7pcn1wx4qjwpvhv8la6afaifv6y5lki2"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision ("2"
+                         "024fn653gmxw4ndmqvg1d3lwmxbvrlllc9iw2zw0c3nkcgcv39sg")))
+    (native-inputs (list ghc-alex ghc-happy))
+    (inputs (list ghc-monads-tf ghc-utf8-string))
+    (home-page "http://github.com/bjpop/language-python")
+    (synopsis "Parse and pretty print Python code in Haskell")
+    (description
+     "@code{language-python} is a Haskell library for lexical analysis,
+parsing and pretty printing Python code.  It supports versions 2.x and 3.x of
+Python.")
+    (license license:bsd-3)
+    (properties '((upstream-name . "language-python")))))
+
 (define-public ghc-lens
   (package
     (name "ghc-lens")