diff mbox series

[bug#70855,64/92] gnu: python-autoflake: Update to 2.3.1.

Message ID 20240509225530.24649-64-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-autoflake): Update to 2.3.1.
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Add check phase replacement.
  [native-inputs]: Add python-hatchling.

Change-Id: I0421107a98b1181a76e1874f23e6aa6e7709e434
---
 gnu/packages/python-xyz.scm | 15 ++++++++++++---
 1 file changed, 12 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0d993fbb208..1f9ebc15e02 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14890,14 +14890,23 @@  (define-public python-flake8-isort
 (define-public python-autoflake
   (package
     (name "python-autoflake")
-    (version "1.3.1")
+    (version "2.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "autoflake" version))
        (sha256
-        (base32 "0nzr057dbmgprp4a52ymafdkdd5zp2wcqf42913xc7hhvvdbj338"))))
-    (build-system python-build-system)
+        (base32 "17lhrmz6h7pz2nald90p8gn3hhzbqwmd78819yf4b1habgf7b2y9"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda _
+              (invoke "python" "test_autoflake.py"))))))
+    (native-inputs
+     (list python-hatchling))
     (propagated-inputs
      (list python-pyflakes))
     (home-page "https://github.com/myint/autoflake")