diff mbox series

[bug#70855,57/92] gnu: python-jaraco-test: Move to pyproject-build-system.

Message ID 20240509225530.24649-57-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-jaraco-test):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Convert <#:phases> to <#:test-flags>.

Change-Id: I926671bc2bb62abae24c26a4bddc304133b2c019
---
 gnu/packages/python-xyz.scm | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0301c53a5b8..3302892ee82 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11943,11 +11943,7 @@  (define-public python-jaraco-test
                 "0h0x8qmvfkfqvwdx2m7kwhn53sg26k8gkaas7s1730ak772zqrvz"))))
     (build-system pyproject-build-system)
     (arguments
-     (list
-      #:phases #~(modify-phases %standard-phases
-                   (replace 'check
-                     (lambda _
-                       (invoke "pytest" "-vv" "-k" "http"))))))
+     (list #:test-flags '(list "-k" "http")))
     (propagated-inputs (list python-jaraco-context python-jaraco-functools))
     (native-inputs (list python-flake8
                          python-pytest