diff mbox series

[bug#70606,rust-team,077/101] gnu: Place rust-downcast-rs-1 in alphabetical order.

Message ID fbc62297f69e78bf4ded8a1eedb0051c51b684d3.1714220246.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-downcast-rs-1, rust-downcast-0.11):
Move variables.

Change-Id: If21ed855105a966f0e64461ff04818a9fbc1335b
---
 gnu/packages/crates-io.scm | 80 +++++++++++++++++++-------------------
 1 file changed, 39 insertions(+), 41 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 084defe5b8..ea2f9f2e94 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -22222,47 +22222,6 @@  (define-public rust-document-features-0.2
 @code{Cargo.toml}.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-downcast-0.11
-  (package
-    (name "rust-downcast")
-    (version "0.11.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "downcast" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1wa78ahlc57wmqyq2ncr80l7plrkgz57xsg7kfzgpcnqac8gld8l"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/fkoep/downcast-rs")
-    (synopsis
-     "Trait for downcasting trait objects back to their original types")
-    (description
-     "This package provides a trait, and utilities, for downcasting trait
-objects back to their original types.  The same as the rust-downcast-rs crate.")
-    (license license:expat)))
-
-(define-public rust-downcast-rs-1
-  (package
-    (name "rust-downcast-rs")
-    (version "1.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "downcast-rs" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0l36kgxqd5djhqwf5abxjmgasdw8n0qsjvw3jdvhi91nj393ba4y"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/marcianx/downcast-rs")
-    (synopsis "Trait object downcasting support using only safe Rust")
-    (description
-     "Trait object downcasting support using only safe Rust.  It supports type
-parameters, associated types, and type constraints.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-dogged-0.2
   (package
     (name "rust-dogged")
@@ -22403,6 +22362,45 @@  (define-public rust-dotenvy-0.15
     (description "This package provides a fork of the dotenv crate.")
     (license license:expat)))
 
+(define-public rust-downcast-0.11
+  (package
+    (name "rust-downcast")
+    (version "0.11.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "downcast" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wa78ahlc57wmqyq2ncr80l7plrkgz57xsg7kfzgpcnqac8gld8l"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/fkoep/downcast-rs")
+    (synopsis
+     "Trait for downcasting trait objects back to their original types")
+    (description
+     "This package provides a trait, and utilities, for downcasting trait
+objects back to their original types.  The same as the rust-downcast-rs crate.")
+    (license license:expat)))
+
+(define-public rust-downcast-rs-1
+  (package
+    (name "rust-downcast-rs")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "downcast-rs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0l36kgxqd5djhqwf5abxjmgasdw8n0qsjvw3jdvhi91nj393ba4y"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/marcianx/downcast-rs")
+    (synopsis "Trait object downcasting support using only safe Rust")
+    (description
+     "Trait object downcasting support using only safe Rust.  It supports type
+parameters, associated types, and type constraints.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-draw-state-0.8
   (package
     (name "rust-draw-state")