diff mbox series

[bug#70606,rust-team,052/101] gnu: Place rust-local-ip-address-0.4 in alphabetical order.

Message ID 6c865f21f167cc08ab96472ad156b4eefbc77846.1714220245.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-local-ip-address-0.4): Move variable.

Change-Id: Ia687d844c8a2114a02ae159603e23f1dd8cbccfd
---
 gnu/packages/crates-io.scm | 52 +++++++++++++++++++-------------------
 1 file changed, 26 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5fd7bbec4b..6d5b29451f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39271,6 +39271,32 @@  (define-public rust-local-channel-0.1
 futures-aware, FIFO queue.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-local-ip-address-0.4
+  (package
+    (name "rust-local-ip-address")
+    (version "0.4.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "local-ip-address" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1xc88i6v43rx5f5im0zadd8nl3k7wvf2lv351q20d05h5w4pzawy"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f  ; Integration test with local IP address.
+       #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+                       ("rust-neli" ,rust-neli-0.5)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-windows-sys" ,rust-windows-sys-0.42))))
+    (home-page "https://github.com/EstebanBorai/local-ip-address")
+    (synopsis
+     "Retrieve system's local IP address and network interfaces/adapters")
+    (description
+     "This package provides retrieving the system's local IP address and
+network interfaces/adapters.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-local-waker-0.1
   (package
     (name "rust-local-waker")
@@ -39339,32 +39365,6 @@  (define-public rust-locale-config-0.3
 by inspecting the system for user preference.")
     (license license:expat)))
 
-(define-public rust-local-ip-address-0.4
-  (package
-    (name "rust-local-ip-address")
-    (version "0.4.9")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "local-ip-address" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1xc88i6v43rx5f5im0zadd8nl3k7wvf2lv351q20d05h5w4pzawy"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:tests? #f  ; Integration test with local IP address.
-       #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
-                       ("rust-neli" ,rust-neli-0.5)
-                       ("rust-thiserror" ,rust-thiserror-1)
-                       ("rust-windows-sys" ,rust-windows-sys-0.42))))
-    (home-page "https://github.com/EstebanBorai/local-ip-address")
-    (synopsis
-     "Retrieve system's local IP address and network interfaces/adapters")
-    (description
-     "This package provides retrieving the system's local IP address and
-network interfaces/adapters.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-lock-api-0.4
   (package
     (name "rust-lock-api")