diff mbox series

[bug#70606,rust-team,014/101] gnu: Place rust-snapbox-macros-0.3 in alphabetical order.

Message ID 083c0b6554232141116706db97b6b726ab7f52ef.1714220243.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-snapbox-macros-0.3): Move variable.

Change-Id: I6ddcea4d2d1bb31099651828e24381b98a67d6af
---
 gnu/packages/crates-io.scm | 71 ++++++++++++++++----------------------
 1 file changed, 29 insertions(+), 42 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b9257501b5..23a1db2bc4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -71770,48 +71770,6 @@  (define-public rust-snap-0.2
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-snappy-cpp" ,rust-snappy-cpp-0.1))))))
 
-(define-public rust-snapbox-macros-0.3
-  (package
-    (name "rust-snapbox-macros")
-    (version "0.3.8")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "snapbox-macros" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0h6yy5h83y17bghi1lq9pw3knbqba1rwns20flian5axn0wbii71"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-anstream" ,rust-anstream-0.6))))
-    (home-page "https://github.com/assert-rs/trycmd/tree/main/crates/snapbox")
-    (synopsis "Snapshot testing toolbox")
-    (description
-     "Snapbox is a snapshot-testing toolbox that is ready to use for verifying
-output from
-
-@itemize
-@item Function return values
-@item CLI stdout/stderr
-@item Filesystem changes
-@end itemize
-
-It is also flexible enough to build your own test harness like @code{trycmd}.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-snapbox-macros-0.2
-  (package
-    (inherit rust-snapbox-macros-0.3)
-    (name "rust-snapbox-macros")
-    (version "0.2.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "snapbox-macros" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0c79lnjcs9yp62y665swv5y5y6088qc256bfr3s7xcnb0izfl7f0"))))))
-
 (define-public rust-snapbox-0.5
   (package
     (name "rust-snapbox")
@@ -71927,6 +71885,35 @@  (define-public rust-snapbox-0.2
         ("rust-walkdir" ,rust-walkdir-2)
         ("rust-yansi" ,rust-yansi-0.5))))))
 
+(define-public rust-snapbox-macros-0.3
+  (package
+    (name "rust-snapbox-macros")
+    (version "0.3.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "snapbox-macros" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0h6yy5h83y17bghi1lq9pw3knbqba1rwns20flian5axn0wbii71"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-anstream" ,rust-anstream-0.6))))
+    (home-page "https://github.com/assert-rs/trycmd/tree/main/crates/snapbox")
+    (synopsis "Snapshot testing toolbox")
+    (description
+     "Snapbox is a snapshot-testing toolbox that is ready to use for verifying
+output from
+
+@itemize
+@item Function return values
+@item CLI stdout/stderr
+@item Filesystem changes
+@end itemize
+
+It is also flexible enough to build your own test harness like @code{trycmd}.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-snappy-cpp-0.1
   (package
     (name "rust-snappy-cpp")