diff mbox series

[bug#70606,rust-team,051/101] gnu: Place rust-magma-0.8 in alphabetical order.

Message ID f14b66c160c93c46875846dbcc0a64c93dc067df.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-magma-0.8): Move variable.

Change-Id: Ie52195b11e8c0025dd46e6018449086c9aabb5f6
---
 gnu/packages/crates-io.scm | 43 +++++++++++++++++++-------------------
 1 file changed, 21 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 66e63b228a..5fd7bbec4b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40432,28 +40432,6 @@  (define-public rust-macrotest-1
      "This package provides test harness for macro expansion in Rust.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-magma-0.8
-  (package
-    (name "rust-magma")
-    (version "0.8.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "magma" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "1w321p30599kc85bb35ps32ykqc9gzpi5b99dsw793nxrypnj9xb"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.4))
-       #:cargo-development-inputs
-       (("rust-cipher" ,rust-cipher-0.4)
-        ("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/block-ciphers")
-    (synopsis "Magma (GOST R 34.12-2015) block cipher")
-    (description "Magma (GOST R 34.12-2015) block cipher")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-magic-crypt-3
   (package
     (name "rust-magic-crypt")
@@ -40514,6 +40492,27 @@  (define-public rust-magic-string-0.3
      "This package provides a MagicString port driven by Rust and N-API.")
     (license license:expat)))
 
+(define-public rust-magma-0.8
+  (package
+    (name "rust-magma")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "magma" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1w321p30599kc85bb35ps32ykqc9gzpi5b99dsw793nxrypnj9xb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-cipher" ,rust-cipher-0.4))
+       #:cargo-development-inputs (("rust-cipher" ,rust-cipher-0.4)
+                                   ("rust-hex-literal" ,rust-hex-literal-0.3))))
+    (home-page "https://github.com/RustCrypto/block-ciphers")
+    (synopsis "Magma (GOST R 34.12-2015) block cipher")
+    (description "Magma (GOST R 34.12-2015) block cipher")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-maildir-0.6
   (package
     (name "rust-maildir")