diff mbox series

[bug#70606,rust-team,035/101] gnu: Place rust-owo-colors-4 in alphabetical order.

Message ID b8cb51a345770c8b351ace01c69169ecd469ad72.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-owo-colors-4, rust-owo-colors-3):
Move variables.

Change-Id: Ib40b15c9f410365881f8f0eb9a746c31b8ed609d
---
 gnu/packages/crates-io.scm | 72 +++++++++++++++++++-------------------
 1 file changed, 36 insertions(+), 36 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a53207af16..607bb76de4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49773,42 +49773,6 @@  (define-public rust-owned-ttf-parser-0.19
      "This package provides a ttf-parser plus support for owned data.")
     (license license:asl2.0)))
 
-(define-public rust-owo-colors-4
-  (package
-    (name "rust-owo-colors")
-    (version "4.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "owo-colors" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0grsk47cllj0s4nc4qxvy4gdhj2lyiglbqx4lmw2m7grdmq59zya"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
-    (home-page "https://github.com/jam1garner/owo-colors")
-    (synopsis "Zero-allocation terminal colors that'll make people go owo")
-    (description
-     "This package provides zero-allocation terminal colors that'll make people go
-owo.")
-    (license license:expat)))
-
-(define-public rust-owo-colors-3
-  (package
-    (inherit rust-owo-colors-4)
-    (name "rust-owo-colors")
-    (version "3.5.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "owo-colors" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0vyvry6ba1xmpd45hpi6savd8mbx09jpmvnnwkf6z62pk6s4zc61"))))
-    (arguments
-     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-1))))))
-
 (define-public rust-owned-ttf-parser-0.6
   (package
     (name "rust-owned-ttf-parser")
@@ -49871,6 +49835,42 @@  (define-public rust-owning-ref-0.3
      (list #:cargo-inputs
            `(("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))))
 
+(define-public rust-owo-colors-4
+  (package
+    (name "rust-owo-colors")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "owo-colors" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0grsk47cllj0s4nc4qxvy4gdhj2lyiglbqx4lmw2m7grdmq59zya"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
+    (home-page "https://github.com/jam1garner/owo-colors")
+    (synopsis "Zero-allocation terminal colors that'll make people go owo")
+    (description
+     "This package provides zero-allocation terminal colors that'll make people go
+owo.")
+    (license license:expat)))
+
+(define-public rust-owo-colors-3
+  (package
+    (inherit rust-owo-colors-4)
+    (name "rust-owo-colors")
+    (version "3.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "owo-colors" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0vyvry6ba1xmpd45hpi6savd8mbx09jpmvnnwkf6z62pk6s4zc61"))))
+    (arguments
+     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-1))))))
+
 (define-public rust-packed-simd-0.3
   (package
     (name "rust-packed-simd")