diff mbox series

[bug#70606,rust-team,031/101] gnu: Place rust-pretty-hex-0.3 in alphabetical order.

Message ID 40b5368e2bc90172646d08e1393d41b2a543d701.1714220243.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-pretty-hex-0.3): Move variable.

Change-Id: Ieb7c62fbd2f99dfc66b2bb02123f300562dca11a
---
 gnu/packages/crates-io.scm | 38 +++++++++++++++++++-------------------
 1 file changed, 19 insertions(+), 19 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dc9324793b..75d962ffc7 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -55590,6 +55590,25 @@  (define-public rust-pretty-env-logger-0.3
         ("rust-chrono" ,rust-chrono-0.4)
         ("rust-env-logger" ,rust-env-logger-0.6))))))
 
+(define-public rust-pretty-hex-0.3
+  (package
+    (name "rust-pretty-hex")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pretty-hex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1mf8xvlfri4impj2paj4azx7hxh7l0i38cjyib1hiikwvlqhiyn6"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:cargo-development-inputs `(("rust-heapless" ,rust-heapless-0.5))))
+    (home-page "https://github.com/wolandr/pretty-hex")
+    (synopsis "Prettified output of hexadecimal byte slices")
+    (description "Pretty hex dump of byte slices in the common style.")
+    (license license:expat)))
+
 (define-public rust-prettyplease-0.2
   (package
     (name "rust-prettyplease")
@@ -55633,25 +55652,6 @@  (define-public rust-prettyplease-0.1
        #:cargo-development-inputs
        (("rust-syn" ,rust-syn-1))))))
 
-(define-public rust-pretty-hex-0.3
-  (package
-    (name "rust-pretty-hex")
-    (version "0.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "pretty-hex" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1mf8xvlfri4impj2paj4azx7hxh7l0i38cjyib1hiikwvlqhiyn6"))))
-    (build-system cargo-build-system)
-    (arguments
-     (list #:cargo-development-inputs `(("rust-heapless" ,rust-heapless-0.5))))
-    (home-page "https://github.com/wolandr/pretty-hex")
-    (synopsis "Prettified output of hexadecimal byte slices")
-    (description "Pretty hex dump of byte slices in the common style.")
-    (license license:expat)))
-
 (define-public rust-prettytable-rs-0.8
   (package
     (name "rust-prettytable-rs")