diff mbox series

[bug#70606,rust-team,089/101] gnu: Place rust-bytesize-1 in alphabetical order.

Message ID 00e348946fe6fd968e48c08c3897592cc5942d61.1714220246.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-bytesize-1): Move variable.

Change-Id: I235de65a90b3efae85095eba12e333a7381d21be
---
 gnu/packages/crates-io.scm | 50 +++++++++++++++++++-------------------
 1 file changed, 25 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 60fd9b330d..52b138502e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -10116,6 +10116,31 @@  (define-public rust-bytes-0.3
        #:cargo-development-inputs
        (("rust-rand" ,rust-rand-0.3))))))
 
+(define-public rust-bytesize-1
+  (package
+    (name "rust-bytesize")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "bytesize" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1k3aak70iwz4s2gsjbxf0ws4xnixqbdz6p2ha96s06748fpniqx3"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-toml" ,rust-toml-0.7))))
+    (home-page "https://github.com/hyunsik/bytesize/")
+    (synopsis "Human-readable byte count representation library for Rust")
+    (description "ByteSize is an utility for human-readable byte count
+representation, with support for both SI and binary units.")
+    (license license:asl2.0)))
+
 (define-public rust-bytestring-1
   (package
     (name "rust-bytestring")
@@ -10207,31 +10232,6 @@  (define-public rust-bzip2-0.4
 exposed as Reader/Writer streams.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-bytesize-1
-  (package
-    (name "rust-bytesize")
-    (version "1.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "bytesize" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1k3aak70iwz4s2gsjbxf0ws4xnixqbdz6p2ha96s06748fpniqx3"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-serde" ,rust-serde-1))
-       #:cargo-development-inputs
-       (("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1)
-        ("rust-toml" ,rust-toml-0.7))))
-    (home-page "https://github.com/hyunsik/bytesize/")
-    (synopsis "Human-readable byte count representation library for Rust")
-    (description "ByteSize is an utility for human-readable byte count
-representation, with support for both SI and binary units.")
-    (license license:asl2.0)))
-
 (define-public rust-bzip2-0.3
   (package
     (inherit rust-bzip2-0.4)