diff mbox series

[bug#70606,rust-team,040/101] gnu: Place rust-notify-debouncer-mini-0.4 in alphabetical order.

Message ID b1e5571cee4b5abe94e9b4535a99d8ac4573b09a.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-notify-debouncer-mini-0.4): Move
variable.

Change-Id: Iee9b5c73b1d7c225c52bffca310fc471b92942d1
---
 gnu/packages/crates-io.scm | 44 +++++++++++++++++++-------------------
 1 file changed, 22 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0469cb8f50..6f6d46e88a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46561,28 +46561,6 @@  (define-public rust-notify-4
        (("rust-tempfile" ,rust-tempfile-3))))
     (license license:cc0)))
 
-(define-public rust-notify-debouncer-mini-0.4
-  (package
-    (name "rust-notify-debouncer-mini")
-    (version "0.4.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "notify-debouncer-mini" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0hwxdbzyx01pzwyld1dk7sc7ak5k3xkjz2l59ppwa7rajwhv4h2x"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
-                       ("rust-log" ,rust-log-0.4)
-                       ("rust-notify" ,rust-notify-6)
-                       ("rust-serde" ,rust-serde-1))))
-    (home-page "https://github.com/notify-rs/notify")
-    (synopsis "Notify mini debouncer")
-    (description "This crate is notify mini debouncer for events.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-notify-debouncer-full-0.3
   (package
     (name "rust-notify-debouncer-full")
@@ -46615,6 +46593,28 @@  (define-public rust-notify-debouncer-full-0.3
      "This package provides a notify event debouncer optimized for ease of use.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-notify-debouncer-mini-0.4
+  (package
+    (name "rust-notify-debouncer-mini")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "notify-debouncer-mini" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0hwxdbzyx01pzwyld1dk7sc7ak5k3xkjz2l59ppwa7rajwhv4h2x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-notify" ,rust-notify-6)
+                       ("rust-serde" ,rust-serde-1))))
+    (home-page "https://github.com/notify-rs/notify")
+    (synopsis "Notify mini debouncer")
+    (description "This crate is notify mini debouncer for events.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-notmuch-0.8
   (package
     (name "rust-notmuch")