diff mbox series

[bug#70606,rust-team,073/101] gnu: Place rust-fakeit-1 in alphabetical order.

Message ID abdfa9379718e00bae41ae79ac73dc3577f1dcff.1714220246.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-fake-simd-0.1, rust-fakeit-1,
rust-fallible-collections-0.4): Move variables.

Change-Id: Ieed66efa1c0d8c7bf1acfeb0dc7e86e802315380
---
 gnu/packages/crates-io.scm | 138 ++++++++++++++++++-------------------
 1 file changed, 67 insertions(+), 71 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fb1a0be53a..0142bf58bf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25269,77 +25269,6 @@  (define-public rust-faccess-0.2
     (description "Simple file accessibility checks in rust.")
     (license license:expat)))
 
-(define-public rust-fakeit-1
-  (package
-    (name "rust-fakeit")
-    (version "1.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "fakeit" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0zsz58zfawf3zk9ig3n7dbd382lgndjx0xxngwsymilcgipr0bfi"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-libmath" ,rust-libmath-0.2)
-                       ("rust-rand" ,rust-rand-0.6)
-                       ("rust-simplerand" ,rust-simplerand-1)
-                       ("rust-uuid" ,rust-uuid-0.8))))
-    (home-page "https://github.com/PumpkinSeed/fakeit")
-    (synopsis "Fake data generator")
-    (description "Fake data generator library with 130+ functions.")
-    (license license:expat)))
-
-(define-public rust-fake-simd-0.1
-  (package
-    (name "rust-fake-simd")
-    (version "0.1.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "fake-simd" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1vfylvk4va2ivqx85603lyqqp0zk52cgbs4n5nfbbbqx577qm2p8"))))
-    (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))
-    (home-page "https://github.com/RustCrypto/utils")
-    (synopsis "Crate for mimicking simd crate on stable Rust")
-    (description
-     "Crate for mimicking simd crate on stable Rust.")
-    (license (list license:asl2.0 license:expat))))
-
-(define-public rust-fallible-collections-0.4
-  (package
-    (name "rust-fallible-collections")
-    (version "0.4.6")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "fallible_collections" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0ma7lga3zqbpzrhl76raljc6y69f38mb6j5yhkk6ldkh531wqmrz"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-hashbrown" ,rust-hashbrown-0.12))))
-    (home-page "https://github.com/vcombey/fallible_collections")
-    (synopsis "Fallible collections implementation in Rust")
-    (description "This library extends the Rust standard collections to return
-a result when an allocation error occurs, ala
-@url{https://github.com/rust-lang/rfcs/blob/master/text/2116-alloc-me-maybe.md,RFC
-2116}.  The API currently proposes a fallible interface for @code{Vec},
-@code{Box}, @code{Arc}, @code{Btree} and @code{Rc}, as well as a
-@code{TryClone} trait which is implemented for primitive Rust traits and a
-fallible format macro.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-failure-0.1
   (package
     (name "rust-failure")
@@ -25393,6 +25322,73 @@  (define-public rust-failure-derive-0.1
     (description "Derives for the failure crate.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-fake-simd-0.1
+  (package
+    (name "rust-fake-simd")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fake-simd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1vfylvk4va2ivqx85603lyqqp0zk52cgbs4n5nfbbbqx577qm2p8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/RustCrypto/utils")
+    (synopsis "Crate for mimicking simd crate on stable Rust")
+    (description "Crate for mimicking simd crate on stable Rust.")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-fakeit-1
+  (package
+    (name "rust-fakeit")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fakeit" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0zsz58zfawf3zk9ig3n7dbd382lgndjx0xxngwsymilcgipr0bfi"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-libmath" ,rust-libmath-0.2)
+                       ("rust-rand" ,rust-rand-0.6)
+                       ("rust-simplerand" ,rust-simplerand-1)
+                       ("rust-uuid" ,rust-uuid-0.8))))
+    (home-page "https://github.com/PumpkinSeed/fakeit")
+    (synopsis "Fake data generator")
+    (description "Fake data generator library with 130+ functions.")
+    (license license:expat)))
+
+(define-public rust-fallible-collections-0.4
+  (package
+    (name "rust-fallible-collections")
+    (version "0.4.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "fallible_collections" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ma7lga3zqbpzrhl76raljc6y69f38mb6j5yhkk6ldkh531wqmrz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-hashbrown" ,rust-hashbrown-0.12))))
+    (home-page "https://github.com/vcombey/fallible_collections")
+    (synopsis "Fallible collections implementation in Rust")
+    (description
+     "This library extends the Rust standard collections to return
+a result when an allocation error occurs, ala
+@url{https://github.com/rust-lang/rfcs/blob/master/text/2116-alloc-me-maybe.md,RFC
+2116}.  The API currently proposes a fallible interface for @code{Vec},
+@code{Box}, @code{Arc}, @code{Btree} and @code{Rc}, as well as a
+@code{TryClone} trait which is implemented for primitive Rust traits and a
+fallible format macro.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-fallible-iterator-0.3
   (package
     (name "rust-fallible-iterator")