diff mbox series

[bug#70606,rust-team,061/101] gnu: Place rust-jsonpath-lib-0.3 in alphabetical order.

Message ID 5a64f2f544534998f01e91be63c7c73903619f78.1714220245.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-jsonpath-lib-0.3,
rust-jsonrpc-core-14): Move variables.

Change-Id: Ia2a121eea6511e177a26ae05b4989f8520f2dad6
---
 gnu/packages/crates-io.scm | 104 ++++++++++++++++++-------------------
 1 file changed, 52 insertions(+), 52 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b72c1a497a..5626623902 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35985,58 +35985,6 @@  (define-public rust-joinery-2
 iterators with a separator.")
     (license license:expat)))
 
-(define-public rust-jsonpath-lib-0.3
-  (package
-    (name "rust-jsonpath-lib")
-    (version "0.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "jsonpath_lib" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0kvp4fargixqlwjvpb3w6f1lvmiysnmj7an5h75wqc42ss8k39pa"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-log" ,rust-log-0.4)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/freestrings/jsonpath")
-    (synopsis "JsonPath engine written in Rust")
-    (description
-     "It is JsonPath engine written in Rust.  It provides a similar API
-interface in Webassembly and Javascript too.")
-    (license license:expat)))
-
-(define-public rust-jsonrpc-core-14
-  (package
-    (name "rust-jsonrpc-core")
-    (version "14.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "jsonrpc-core" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0qkvgkr05sg0j25jqgw7zcw4r1agzg8gnfnrmw1rgyqz283p6x50"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-futures" ,rust-futures-0.1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-serde" ,rust-serde-1)
-        ("rust-serde-derive" ,rust-serde-derive-1)
-        ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/paritytech/jsonrpc")
-    (synopsis "Transport agnostic Rust implementation of JSON-RPC 2.0")
-    (description
-     "This package provides a transport agnostic Rust implementation of
-JSON-RPC 2.0 specification.")
-    (license license:expat)))
-
 (define-public rust-js-sys-0.3
   (package
     (name "rust-js-sys")
@@ -36108,6 +36056,58 @@  (define-public rust-json-deserializer-0.4
      "This package provides a performant library to deserialize JSON.")
     (license license:asl2.0)))
 
+(define-public rust-jsonpath-lib-0.3
+  (package
+    (name "rust-jsonpath-lib")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "jsonpath_lib" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0kvp4fargixqlwjvpb3w6f1lvmiysnmj7an5h75wqc42ss8k39pa"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-log" ,rust-log-0.4)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/freestrings/jsonpath")
+    (synopsis "JsonPath engine written in Rust")
+    (description
+     "It is JsonPath engine written in Rust.  It provides a similar API
+interface in Webassembly and Javascript too.")
+    (license license:expat)))
+
+(define-public rust-jsonrpc-core-14
+  (package
+    (name "rust-jsonrpc-core")
+    (version "14.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "jsonrpc-core" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0qkvgkr05sg0j25jqgw7zcw4r1agzg8gnfnrmw1rgyqz283p6x50"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-futures" ,rust-futures-0.1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/paritytech/jsonrpc")
+    (synopsis "Transport agnostic Rust implementation of JSON-RPC 2.0")
+    (description
+     "This package provides a transport agnostic Rust implementation of
+JSON-RPC 2.0 specification.")
+    (license license:expat)))
+
 (define-public rust-juliex-0.3
   (package
     (name "rust-juliex")