diff mbox series

[bug#70606,rust-team,010/101] gnu: Place rust-synchronoise-1 in alphabetical order.

Message ID 1ef7a38a11ae89a3ad93a3a024cd457ddbebd0d9.1714220242.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-synchronoise-1): Move variable.

Change-Id: I667a4af01355324ead56d3d7049ed749d4caec8b
---
 gnu/packages/crates-io.scm | 43 +++++++++++++++++++-------------------
 1 file changed, 21 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 5b8cd25da8..93064455b3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -75990,28 +75990,6 @@  (define-public rust-syn-test-suite-0.0.0
     (description "Test suite of the syn crate.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-synchronoise-1
-  (package
-    (name "rust-synchronoise")
-    (version "1.0.1")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "synchronoise" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1wnylkdf84520ks7a70fnwds2wibxmnkgqzz3j6ww9n61wwh3g1x"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-crossbeam-queue" ,rust-crossbeam-queue-0.3))))
-    (home-page "https://github.com/QuietMisdreavus/synchronoise")
-    (synopsis "Synchronization primitives")
-    (description
-     "This package provides synchronization primitives that build upon the
-standard library.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-sync-wrapper-0.1
   (package
     (name "rust-sync-wrapper")
@@ -76037,6 +76015,27 @@  (define-public rust-sync-wrapper-0.1
 the absence of concurrency.")
     (license license:asl2.0)))
 
+(define-public rust-synchronoise-1
+  (package
+    (name "rust-synchronoise")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "synchronoise" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1wnylkdf84520ks7a70fnwds2wibxmnkgqzz3j6ww9n61wwh3g1x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-crossbeam-queue" ,rust-crossbeam-queue-0.3))))
+    (home-page "https://github.com/QuietMisdreavus/synchronoise")
+    (synopsis "Synchronization primitives")
+    (description
+     "This package provides synchronization primitives that build upon the
+standard library.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-synom-0.11
   (package
     (name "rust-synom")