diff mbox series

[bug#70606,rust-team,038/101] gnu: Place rust-once-cell-1 in alphabetical order.

Message ID e133a37a3c902804b33e0bf2f18f9b023bdc033e.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-once-cell-1): Move variable.

Change-Id: I74f6c9f3389cc6f86e88f985362dbfa2751120c3
---
 gnu/packages/crates-io.scm | 60 +++++++++++++++++++-------------------
 1 file changed, 30 insertions(+), 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6d3392b063..1acf8dd6c3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -48420,6 +48420,36 @@  (define-public rust-omnipath-0.1
     (description "This package provides a path utility library.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-once-cell-1
+  (package
+    (name "rust-once-cell")
+    (version "1.19.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "once_cell" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "14kvw7px5z96dk4dwdm1r9cqhhy2cyj1l5n5b29mynbb8yr15nrz"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-critical-section" ,rust-critical-section-1)
+        ("rust-parking-lot-core" ,rust-parking-lot-core-0.9)
+        ("rust-portable-atomic" ,rust-portable-atomic-1))
+       #:cargo-development-inputs
+       (("rust-critical-section" ,rust-critical-section-1)
+        ("rust-regex" ,rust-regex-1))))
+    (home-page "https://github.com/matklad/once_cell")
+    (synopsis "Single assignment cells and lazy values")
+    (description
+     "This package provides two new cell-like types, @code{unsync::OnceCell}
+and @code{sync::OnceCell}.  OnceCell might store arbitrary non-copy types, can
+be assigned to at most once and provide direct access to the stored
+contents.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-onig-6
   (package
     (name "rust-onig")
@@ -48473,36 +48503,6 @@  (define-public rust-onig-sys-69.6
 other crates to create safe wrappers around Oniguruma.")
     (license license:expat)))
 
-(define-public rust-once-cell-1
-  (package
-    (name "rust-once-cell")
-    (version "1.19.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "once_cell" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "14kvw7px5z96dk4dwdm1r9cqhhy2cyj1l5n5b29mynbb8yr15nrz"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-critical-section" ,rust-critical-section-1)
-        ("rust-parking-lot-core" ,rust-parking-lot-core-0.9)
-        ("rust-portable-atomic" ,rust-portable-atomic-1))
-       #:cargo-development-inputs
-       (("rust-critical-section" ,rust-critical-section-1)
-        ("rust-regex" ,rust-regex-1))))
-    (home-page "https://github.com/matklad/once_cell")
-    (synopsis "Single assignment cells and lazy values")
-    (description
-     "This package provides two new cell-like types, @code{unsync::OnceCell}
-and @code{sync::OnceCell}.  OnceCell might store arbitrary non-copy types, can
-be assigned to at most once and provide direct access to the stored
-contents.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-oorandom-11
   (package
     (name "rust-oorandom")