diff mbox series

[bug#70606,rust-team,008/101] gnu: Place rust-tikv-jemalloc-ctl-0.4 in alphabetical order.

Message ID c746a6c31b250d31be611f80d5fa321162506763.1714220242.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-tikv-jemalloc-ctl-0.4): Move variable.

Change-Id: I1d929d143216f638dc55603cbd14d294fa790adf
---
 gnu/packages/crates-io.scm | 66 +++++++++++++++++++-------------------
 1 file changed, 33 insertions(+), 33 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 19d700eb74..7d96240905 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -79541,6 +79541,39 @@  (define-public rust-thrift-0.13
         ("rust-ordered-float" ,rust-ordered-float-1)
         ("rust-threadpool" ,rust-threadpool-1))))))
 
+(define-public rust-tikv-jemalloc-ctl-0.4
+  (package
+    (name "rust-tikv-jemalloc-ctl")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "tikv-jemalloc-ctl" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-paste" ,rust-paste-0.1)
+        ("rust-tikv-jemalloc-sys"
+         ,rust-tikv-jemalloc-sys-0.4))
+       #:cargo-development-inputs
+       (("rust-tikv-jemallocator"
+         ,rust-tikv-jemallocator-0.4))))
+    (home-page
+     "https://github.com/tikv/jemallocator")
+    (synopsis
+     "Safe wrapper over jemalloc's control and introspection APIs")
+    (description
+     "This package provides a safe wrapper over jemalloc's control and
+introspection APIs.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-tikv-jemalloc-sys-0.4
   (package
     (name "rust-tikv-jemalloc-sys")
@@ -79598,39 +79631,6 @@  (define-public rust-tikv-jemallocator-0.4
      "This package provides a Rust allocator backed by jemalloc.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-tikv-jemalloc-ctl-0.4
-  (package
-    (name "rust-tikv-jemalloc-ctl")
-    (version "0.4.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "tikv-jemalloc-ctl" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-libc" ,rust-libc-0.2)
-        ("rust-paste" ,rust-paste-0.1)
-        ("rust-tikv-jemalloc-sys"
-         ,rust-tikv-jemalloc-sys-0.4))
-       #:cargo-development-inputs
-       (("rust-tikv-jemallocator"
-         ,rust-tikv-jemallocator-0.4))))
-    (home-page
-     "https://github.com/tikv/jemallocator")
-    (synopsis
-     "Safe wrapper over jemalloc's control and introspection APIs")
-    (description
-     "This package provides a safe wrapper over jemalloc's control and
-introspection APIs.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-time-0.3
   (package
     (name "rust-time")