diff mbox series

[bug#70606,rust-team,033/101] gnu: Place rust-perf-event-open-sys-1 in alphabetical order.

Message ID 2f45e70c46d840ed974f7ead4f06d4a457d59d78.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-perf-event-open-sys-1): Move
variable.

Change-Id: I3b2880b3bf4a5089ceb66ddd715bcc4c0ee62106
---
 gnu/packages/crates-io.scm | 50 ++++++++++++++++++--------------------
 1 file changed, 23 insertions(+), 27 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index caf03a9d2d..45b68e87b9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -52152,33 +52152,6 @@  (define-public rust-peresil-0.3
      "This package provides a simple and simplistic string parsing library.")
     (license license:expat)))
 
-(define-public rust-perf-event-open-sys-1
-  (package
-    (name "rust-perf-event-open-sys")
-    (version "1.0.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "perf-event-open-sys" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "06jnb2jkwjinpj4hc41kbwsqbxdb1ywy5vci4ggly8rcvbsyv6yf"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-libc" ,rust-libc-0.2))))
-    (home-page
-     "https://github.com/jimblandy/perf-event-open-sys.git")
-    (synopsis
-     "Unsafe, direct bindings for Linux's perf_event_open system call")
-    (description
-     "This package provides a unsafe, direct bindings for Linux's
-perf_event_open system call, with associated types and constants.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-perf-event-0.4
   (package
     (name "rust-perf-event")
@@ -52206,6 +52179,29 @@  (define-public rust-perf-event-0.4
      "This package provides a Rust interface to Linux performance monitoring.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-perf-event-open-sys-1
+  (package
+    (name "rust-perf-event-open-sys")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "perf-event-open-sys" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "06jnb2jkwjinpj4hc41kbwsqbxdb1ywy5vci4ggly8rcvbsyv6yf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-libc" ,rust-libc-0.2))))
+    (home-page "https://github.com/jimblandy/perf-event-open-sys.git")
+    (synopsis
+     "Unsafe, direct bindings for Linux's perf_event_open system call")
+    (description
+     "This package provides a unsafe, direct bindings for Linux's
+perf_event_open system call, with associated types and constants.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-permutohedron-0.2
   (package
     (name "rust-permutohedron")