diff mbox series

[bug#70606,rust-team,005/101] gnu: Place rust-tree-magic-0.2 in alphabetical order.

Message ID 73721952151651d95273f9a9e764e53e5dc3694d.1714220242.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:34 p.m. UTC
* gnu/packages/crates-io.scm (rust-tree-magic-0.2): Move variable.

Change-Id: I9ce8a7021194eef399bd5a89cda3d5629aeac6dd
---
 gnu/packages/crates-io.scm | 64 +++++++++++++++++++-------------------
 1 file changed, 32 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 68e5b7f41b..03810b2dde 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -83397,6 +83397,38 @@  (define-public rust-trash-2
         ("rust-rand" ,rust-rand-0.8)
         ("rust-serial-test" ,rust-serial-test-0.6))))))
 
+(define-public rust-tree-magic-0.2
+  (package
+    (name "rust-tree-magic")
+    (version "0.2.3")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "tree_magic" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "0adndj775gjcvkf7yxdfj3pl39fcdiibswwgff23lm9yrrkr7ndi"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-clap" ,rust-clap-2)
+         ("rust-fnv" ,rust-fnv-1)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-nom" ,rust-nom-3)
+         ("rust-num-cpus" ,rust-num-cpus-1)
+         ("rust-parking-lot" ,rust-parking-lot-0.10)
+         ("rust-petgraph" ,rust-petgraph-0.5)
+         ("rust-scoped-threadpool" ,rust-scoped-threadpool-0.1)
+         ("rust-tabwriter" ,rust-tabwriter-1)
+         ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/aahancoc/tree_magic/")
+    (synopsis "Determines the MIME type")
+    (description "This package determines the MIME type of a file by
+traversing a filetype tree.")
+    (license license:expat)))
+
 (define-public rust-tree-magic-db-3
   (package
     (name "rust-tree-magic-db")
@@ -83445,38 +83477,6 @@  (define-public rust-tree-magic-mini-3
      "Determines the MIME type of a file by traversing a filetype tree.")
     (license license:expat)))
 
-(define-public rust-tree-magic-0.2
-  (package
-    (name "rust-tree-magic")
-    (version "0.2.3")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "tree_magic" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "0adndj775gjcvkf7yxdfj3pl39fcdiibswwgff23lm9yrrkr7ndi"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:skip-build?
-        #t
-        #:cargo-inputs
-        (("rust-clap" ,rust-clap-2)
-         ("rust-fnv" ,rust-fnv-1)
-         ("rust-lazy-static" ,rust-lazy-static-1)
-         ("rust-nom" ,rust-nom-3)
-         ("rust-num-cpus" ,rust-num-cpus-1)
-         ("rust-parking-lot" ,rust-parking-lot-0.10)
-         ("rust-petgraph" ,rust-petgraph-0.5)
-         ("rust-scoped-threadpool" ,rust-scoped-threadpool-0.1)
-         ("rust-tabwriter" ,rust-tabwriter-1)
-         ("rust-walkdir" ,rust-walkdir-2))))
-    (home-page "https://github.com/aahancoc/tree_magic/")
-    (synopsis "Determines the MIME type")
-    (description "This package determines the MIME type of a file by
-traversing a filetype tree.")
-    (license license:expat)))
-
 (define-public rust-treeline-0.1
   (package
     (name "rust-treeline")