diff mbox series

[bug#70606,rust-team,039/101] gnu: Place rust-ntest-proc-macro-helper-0.8 in alphabetical order.

Message ID 7b0a22df8ae5a8d4fea38ed4d67351448db32f8f.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-ntest-proc-macro-helper-0.8,
rust-ntest-proc-macro-helper-0.7): Move variables.

Change-Id: I8bf4624e8a8a056e543b4f05844a596452c49637
---
 gnu/packages/crates-io.scm | 60 +++++++++++++++++++-------------------
 1 file changed, 30 insertions(+), 30 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1acf8dd6c3..0469cb8f50 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -46800,6 +46800,36 @@  (define-public rust-ntest-0.7
         ("rust-ntest-timeout" ,rust-ntest-timeout-0.7))
        #:cargo-development-inputs (("rust-tokio" ,rust-tokio-1))))))
 
+(define-public rust-ntest-proc-macro-helper-0.8
+  (package
+    (name "rust-ntest-proc-macro-helper")
+    (version "0.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "ntest_proc_macro_helper" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "154r3r9nnnp6qjzlayc54213bdrgdk8b68jjnn1xcyd6cz92iqx0"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/becheran/ntest")
+    (synopsis "Helper functions for the procedural macros used in ntest")
+    (description "This package provides helper functions for the procedural
+macros used in ntest.")
+    (license license:expat)))
+
+(define-public rust-ntest-proc-macro-helper-0.7
+  (package
+    (inherit rust-ntest-proc-macro-helper-0.8)
+    (name "rust-ntest-proc-macro-helper")
+    (version "0.7.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ntest_proc_macro_helper" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0lkyfx97aynbm7cnhzyc9cr0rpq1xzng1hwmzizbf1a6855y6llg"))))))
+
 (define-public rust-ntest-test-cases-0.9
   (package
     (name "rust-ntest-test-cases")
@@ -46917,36 +46947,6 @@  (define-public rust-ntest-timeout-0.7
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))))
 
-(define-public rust-ntest-proc-macro-helper-0.8
-  (package
-    (name "rust-ntest-proc-macro-helper")
-    (version "0.8.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "ntest_proc_macro_helper" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32 "154r3r9nnnp6qjzlayc54213bdrgdk8b68jjnn1xcyd6cz92iqx0"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/becheran/ntest")
-    (synopsis "Helper functions for the procedural macros used in ntest")
-    (description "This package provides helper functions for the procedural
-macros used in ntest.")
-    (license license:expat)))
-
-(define-public rust-ntest-proc-macro-helper-0.7
-  (package
-    (inherit rust-ntest-proc-macro-helper-0.8)
-    (name "rust-ntest-proc-macro-helper")
-    (version "0.7.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "ntest_proc_macro_helper" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0lkyfx97aynbm7cnhzyc9cr0rpq1xzng1hwmzizbf1a6855y6llg"))))))
-
 (define-public rust-ntex-bytes-0.1
   (package
     (name "rust-ntex-bytes")