diff mbox series

[bug#70606,rust-team,049/101] gnu: Place rust-matchit-0.7 in alphabetical order.

Message ID 3fee600f22d43c9fe963bf3cd7b3ea499486ea43.1714220244.git.herman@rimm.ee
State New
Headers show
Series [bug#70606,rust-team,001/101] gnu: Place rust-xxhash-rust-0.8 in alphabetical order. | expand

Commit Message

Herman Rimm April 27, 2024, 12:35 p.m. UTC
* gnu/packages/crates-io.scm (rust-matchit-0.7, rust-matches-0.1): Move
variables.

Change-Id: I2e9b5d1ffc4fefe2ea3a82b098cb963e7ec0baca
---
 gnu/packages/crates-io.scm | 76 +++++++++++++++++++-------------------
 1 file changed, 37 insertions(+), 39 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 187c81d7cf..0a1fc4574e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40872,26 +40872,6 @@  (define-public rust-mas-iana-0.7
 OAuth 2.0.")
     (license license:asl2.0)))
 
-(define-public rust-matchit-0.7
-  (package
-    (name "rust-matchit")
-    (version "0.7.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "matchit" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "156bgdmmlv4crib31qhgg49nsjk88dxkdqp80ha2pk2rk6n6ax0f"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t))   ; Cut the dependency tree.
-    (home-page "https://github.com/ibraheemdev/matchit")
-    (synopsis "High performance, zero-copy URL router")
-    (description
-     "This package provides a high performance, zero-copy URL router.")
-    (license (list license:expat license:bsd-3))))
-
 (define-public rust-match-cfg-0.1
   (package
     (name "rust-match-cfg")
@@ -40915,25 +40895,6 @@  (define-public rust-match-cfg-0.1
 statement, the first matching branch is the item that gets emitted.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-matches-0.1
-  (package
-    (name "rust-matches")
-    (version "0.1.10")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "matches" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-         (base32
-          "1994402fq4viys7pjhzisj4wcw894l53g798kkm2y74laxk0jci5"))))
-    (build-system cargo-build-system)
-    (home-page "https://github.com/SimonSapin/rust-std-candidates")
-    (synopsis "Macro to evaluate whether an expression matches a pattern")
-    (description "This package provides a macro to evaluate, as a boolean,
-whether an expression matches a pattern.")
-    (license license:expat)))
-
 (define-public rust-matchers-0.1
   (package
     (name "rust-matchers")
@@ -40977,6 +40938,43 @@  (define-public rust-matchers-0.0
      `(#:cargo-inputs
        (("rust-regex-automata" ,rust-regex-automata-0.1))))))
 
+(define-public rust-matches-0.1
+  (package
+    (name "rust-matches")
+    (version "0.1.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "matches" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1994402fq4viys7pjhzisj4wcw894l53g798kkm2y74laxk0jci5"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/SimonSapin/rust-std-candidates")
+    (synopsis "Macro to evaluate whether an expression matches a pattern")
+    (description "This package provides a macro to evaluate, as a boolean,
+whether an expression matches a pattern.")
+    (license license:expat)))
+
+(define-public rust-matchit-0.7
+  (package
+    (name "rust-matchit")
+    (version "0.7.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "matchit" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "156bgdmmlv4crib31qhgg49nsjk88dxkdqp80ha2pk2rk6n6ax0f"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/ibraheemdev/matchit")
+    (synopsis "High performance, zero-copy URL router")
+    (description
+     "This package provides a high performance, zero-copy URL router.")
+    (license (list license:expat license:bsd-3))))
 
 (define-public rust-matrixcompare-0.3
   (package