diff mbox series

[bug#70855,90/92] gnu: python-cssselect2: Move to pyproject-build-system.

Message ID 20240509225530.24649-90-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-web.scm (python-cssselect2):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Remove uneeded 'check phase replacement.

Change-Id: I0bdcf546d24bd738d5c547c36faa91483408d1ab
---
 gnu/packages/python-web.scm | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5f07b3cfc50..05413fd2e7e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5930,7 +5930,7 @@  (define-public python-cssselect2
        (uri (pypi-uri "cssselect2" version))
        (sha256
         (base32 "1j2fcr217rsvkipsg6zjq03rl64rxnvb5hqqpx0dv58fhspvkywk"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -5941,11 +5941,7 @@  (define-public python-cssselect2
                (("'pytest-flake8',") "")
                (("'pytest-isort',") "")
                (("--flake8") "")
-               (("--isort") ""))))
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (lambda _ (invoke "pytest"))))))))
+               (("--isort") "")))))))
     (propagated-inputs
      (list python-tinycss2))
     (native-inputs