diff mbox series

[bug#70855,60/92] gnu: python-sparse: Move to pyproject-build-system.

Message ID 20240509225530.24649-60-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-sparse):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove unneeded field.

Change-Id: If3f785ede09ef79384b66166ad2f1c2a5f6e7c84
---
 gnu/packages/python-xyz.scm | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3302892ee82..0c88e48870c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8733,14 +8733,7 @@  (define-public python-sparse
        (sha256
         (base32
          "1600xad37mff46xg80cy6bi3l2n6jm69j7sl19rzdmkcgyijfn2z"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "python" "-m" "pytest" "-v")))))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-numba python-numpy python-scipy))
     (native-inputs