diff mbox series

[bug#70855,40/92] gnu: python-flask-login: Move to pyproject-build-system.

Message ID 20240509225530.24649-40-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-web.scm (python-flask-login):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove uneeded field.

Change-Id: I9f3abb36b642ad2860c68f13f9d9e8b8b5f40811
---
 gnu/packages/python-web.scm | 9 +--------
 1 file changed, 1 insertion(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 88dc08c18f6..4d3fc75bb3c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4856,14 +4856,7 @@  (define-public python-flask-login
        (file-name (git-file-name name version))
        (sha256
         (base32 "12yw01ccgjn9c88cbkrd6k1ykjxd8fxip2b1isvxjirphnlqhn9g"))))
-    (build-system python-build-system)
-    (arguments
-     (list #:phases
-           #~(modify-phases %standard-phases
-               (replace 'check
-                 (lambda* (#:key tests? #:allow-other-keys)
-                   (when tests?
-                     (invoke "pytest" "-vv" "-c" "/dev/null")))))))
+    (build-system pyproject-build-system)
     (propagated-inputs
      (list python-flask))
     (native-inputs