diff mbox series

[bug#70855,23/92] gnu: python-conda-package-handling: Move to pyproject-build-system.

Message ID 20240509225530.24649-23-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/package-management.scm (python-conda-package-handling):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Remove check phase replacement.

Change-Id: Ib8edf966b877c6fd5f7ee6151839d4272d65b17d
---
 gnu/packages/package-management.scm | 8 ++------
 1 file changed, 2 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index a01c9faab13..949c42e274b 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1130,18 +1130,14 @@  (define-public python-conda-package-handling
        (sha256
         (base32
          "1dq6f5ks3cinb355x712bls9bvv6bli6x3c43sdkqvawdw8xgv9j"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'use-unmodified-libarchive
            (lambda _
              (substitute* "setup.py"
-               (("archive_and_deps") "archive"))))
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             (invoke "pytest" "-vv" "tests"))))))
+               (("archive_and_deps") "archive")))))))
     (propagated-inputs
      (list python-six python-tqdm))
     (inputs