diff mbox series

[bug#70855,73/92] gnu: python-uqbar: Upgrade to python-team branch.

Message ID 20240509225530.24649-73-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/graphviz.scm (python-uqbar): Upgrade to python-team
branch's changes.
  [arguments]<#:test-flags>: Ignore failing tests.
  [propagated-inputs]: Replace python-sphinx by python-sphinx-5.

Change-Id: I07122f953e806081d9134d39e16675eb0f839bbc
---
 gnu/packages/graphviz.scm | 18 +++++++++++++++---
 1 file changed, 15 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 8ef3642e7e7..b6c46a9d9ec 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -215,7 +215,15 @@  (define-public python-uqbar
        (patches (search-patches "python-uqbar-python3.10.patch"))))
     (build-system pyproject-build-system)
     (arguments
-     (list #:test-flags '(list "tests")))
+     (list #:test-flags
+           '(list "tests"
+                  "-k" (string-append
+                        "not test_interpret_code_blocks_02 "
+                        "and not test_find_executable "
+                        "and not test_sphinx_api_1 "
+                        "and not test_sphinx_book_text_cached "
+                        "and not test_sphinx_book_text_uncached "
+                        "and not test_sphinx_book_text_broken_strict"))))
     (native-inputs
      (list graphviz
            python-flake8
@@ -224,8 +232,12 @@  (define-public python-uqbar
            python-pytest
            python-pytest-cov))
     (propagated-inputs
-     (list python-black python-sphinx python-sphinx-rtd-theme
-           python-unidecode))
+     (list python-black python-sphinx-5 python-unidecode
+           (package/inherit python-sphinx-rtd-theme
+             (propagated-inputs
+              (modify-inputs
+                  (package-propagated-inputs python-sphinx-rtd-theme)
+                (replace "python-sphinx" python-sphinx-5))))))
     (home-page "https://github.com/josiah-wolf-oberholtzer/uqbar")
     (synopsis "Tools for building documentation with Sphinx, Graphviz and LaTeX")
     (description