diff mbox series

[bug#70855,50/92] gnu: python-pytest-toolbox: Move to pyproject-build-system.

Message ID 20240509225530.24649-50-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-check.scm (python-pytest-toolbox):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Restrict 'check phase replacement to
  'pre-check phase.

Change-Id: Id0804db32d30314076d1e411711881bbe3a3f6e1
---
 gnu/packages/python-check.scm | 20 +++++++++-----------
 1 file changed, 9 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f2a355bb413..ccda2042fb6 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1481,18 +1481,16 @@  (define-public python-pytest-toolbox
        (file-name (git-file-name name version))
        (sha256
         (base32 "1wqkr3g5gmqdxmhzfsxbwy8pm3cadaj6a8cxq58w9bacly4hqbh0"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-             (when tests?
-               (substitute* "setup.cfg"
-                 ((".*timeout.*") ""))
-               ;; Make the installed plugin discoverable by Pytest.
-               (add-installed-pythonpath inputs outputs)
-               (invoke "pytest" "-vv")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'pre-check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                (substitute* "setup.cfg"
+                  ((".*timeout.*") ""))))))))
     (native-inputs
      (list python-pydantic python-pytest python-pytest-isort))
     (home-page "https://github.com/samuelcolvin/pytest-toolbox")