diff mbox series

[bug#70855,56/92] gnu: python-jaraco-packaging: Move to pyproject-build-system.

Message ID 20240509225530.24649-56-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-jaraco-packaging):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Ignore failing tests.

Change-Id: Ied9d42afe9b8ae30d2a3587e4ead770c8153c3c1
---
 gnu/packages/python-xyz.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93d2a5bb07b..0301c53a5b8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11911,7 +11911,10 @@  (define-public python-jaraco-packaging
         (sha256
           (base32
             "0zimrnkh33b9g8ffw11mjh6kvs54cy5gcjw1h5cl1r7dc833dmkm"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:test-flags
+           '(list "-k" "not project and not test_revived_distribution")))
     (propagated-inputs
      (list python-pytest
            python-pytest-checkdocs