diff mbox series

[bug#70855,46/92] gnu: abjad: Update to 3.19.

Message ID 20240509225530.24649-46-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/music.scm (abjad): Update to 3.19.
  [arguments]: Remove uneeded field.
  [native-inputs]: Remove all native-inputs except python-pytest.

Change-Id: Iad5b855734650d15dd0a2a8db6312e8d9a3de24a
---
 gnu/packages/music.scm | 31 +++----------------------------
 1 file changed, 3 insertions(+), 28 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 38133cedc9e..b5895b9a494 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1684,8 +1684,7 @@  (define-public music21
 (define-public abjad
   (package
     (name "abjad")
-    ;; XXX: The latest version which supports current Guix's Python 3.9.9.
-    (version "3.4")
+    (version "3.19")
     (source
      (origin
        (method git-fetch)
@@ -1694,36 +1693,12 @@  (define-public abjad
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0s63vk9fifp0im9c31kb9ck39mbaxhrls993d8fvg0nkg41z1jnz"))))
+        (base32 "1cgcnmwzxx2hr21pqm1hbsknpad748yw3gf7jncsb3w1azhjypzm"))))
     (build-system pyproject-build-system)
-    (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          ;; XXX. Permit newer version of uqbar, remove for >3.4. Remove in
-          ;; the next update.
-          (add-after 'unpack 'loosen-requirements
-            (lambda _
-              (substitute* "setup.py"
-                ((", <0\\.5\\.0") ""))))
-          ;; FIXME: Check why it's failing with this: Note: compilation failed
-          ;; and \version outdated, did you update input syntax with
-          ;; convert-ly?
-          (add-before 'check 'disable-failing-tests
-            (lambda _
-              (substitute* "tests/test_ext_sphinx.py"
-                (("def test_ext_sphinx_01") "def __off_test_ext_sphinx_01")))))))
     (inputs
      (list lilypond))
     (native-inputs
-     (list python-flake8
-           python-isort
-           python-mypy
-           python-pytest
-           python-pytest-cov
-           python-pytest-helpers-namespace
-           python-six
-           python-sphinx-autodoc-typehints))
+     (list python-pytest))
     (propagated-inputs
      (list python-quicktions
            python-ply