diff mbox series

[bug#70855,53/92] gnu: python-jaraco-classes: Move to pyproject-build-system.

Message ID 20240509225530.24649-53-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-jaraco-classes):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Convert <#:phases> to <#:test-flags>.

Change-Id: I8fbe633db7533f933a342b47a4a2191ccf13a8c5
---
 gnu/packages/python-xyz.scm | 13 +++----------
 1 file changed, 3 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 323bbfc1b4d..32991d57a1f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11722,17 +11722,10 @@  (define-public python-jaraco-classes
        (uri (pypi-uri "jaraco.classes" version))
        (sha256
         (base32 "0d6g7qvfv1jlzbzh6asprqdblqd59grvlvr3nwbdqdqrmwlbfm7d"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                ;; Do not test the myproject.toml build as it tries to pull
-                ;; dependencies from the Internet.
-                (invoke "pytest" "-vv" "-k" "not project")))))))
+     (list  ; Do not test the myproject.toml build as it pulls dependencies.
+      #:test-flags '(list "-k" "not project")))
     (native-inputs
      (list python-pytest
            python-pytest-black