diff mbox series

[bug#70855,42/92] gnu: python-amqp: Move to pyproject-build-system.

Message ID 20240509225530.24649-42-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-amqp):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:phases>: Remove unneeded field.
  <#:test-flags>: Ignore failing test.

Change-Id: I8fb99db7fbd6c669a929b95829f9db2fea0691a5
---
 gnu/packages/python-xyz.scm | 14 +++-----------
 1 file changed, 3 insertions(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 169c1df2112..1d324af423e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19620,18 +19620,10 @@  (define-public python-amqp
        (uri (pypi-uri "amqp" version))
        (sha256
         (base32 "1qmmffiy48nady7is8529vxcyqbq88v5zgawqr3fk4q8rkz166rc"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     (list
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-vv"
-                        "-c" "/dev/null" ;take control over pytest options
-                        ;; Integration tests require network connectivity.
-                        "--ignore" "t/integration")))))))
+     (list  ; Integration tests require network connectivity.
+      #:test-flags '(list "--ignore=t/integration")))
     (native-inputs (list python-pytest))
     (propagated-inputs (list python-vine))
     (home-page "https://github.com/celery/py-amqp")