diff mbox series

[bug#70855,29/92] gnu: python-pypujs: Improve package style.

Message ID 20240509225530.24649-29-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-pypujs): Improve package style.
  [arguments]<#:test-flags>: Use it in place of check phase
  replacement.
  <#:phases>: Clarify phase disable-pyramid.

Change-Id: If8073cc4e9a8a86003000e7157985fe382de7b4f
---
 gnu/packages/python-xyz.scm | 15 +++++----------
 1 file changed, 5 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0863ce8fa01..6d6169ec1e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6453,18 +6453,13 @@  (define-public python-pypugjs
     (build-system pyproject-build-system)
     (arguments
      (list
+      #:test-flags '(list "pypugjs/testsuite/")
       #:phases #~(modify-phases %standard-phases
-                   ;; Our pyramid is outdated and pyramid-mako is not packaged.
                    (add-after 'unpack 'disable-pyramid
-                     (lambda* (#:key inputs #:allow-other-keys)
-                       (substitute* "setup.py"
-                         (("'pyramid")
-                          "#'pyramid"))))
-                   (replace 'check
-                     (lambda* (#:key tests? #:allow-other-keys)
-                       (when tests?
-                         (invoke "python" "-m" "pytest" "-v"
-                                 "pypugjs/testsuite/")))))))
+                     (lambda _
+                       ;; pyramid is outdated and pyramid-mako is unpackaged.
+                       (substitute* "setup.cfg"
+                         (("'(pyramid|pyramid-mako)[^']*',") "")))))))
     (native-inputs (list python-coverage
                          python-django
                          python-jinja2