diff mbox series

[bug#70855,71/92] gnu: Add python-sphinx-autodoc-typehints-5.

Message ID 20240509225530.24649-71-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/sphinx.scm (python-sphinx-autodoc-typehints-5): New variable.

Change-Id: I465979829851681635d1073658f262a96758cfb5
---
 gnu/packages/sphinx.scm | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 195cd63ae61..e6668146849 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1162,6 +1162,13 @@  (define-public python-sphinx-autodoc-typehints
 documenting acceptable argument types and return value types of functions.")
     (license license:expat)))
 
+(define-public python-sphinx-autodoc-typehints-5
+  (package/inherit python-sphinx-autodoc-typehints
+    (propagated-inputs
+     (modify-inputs
+         (package-propagated-inputs python-sphinx-autodoc-typehints)
+       (replace "python-sphinx" python-sphinx-5)))))
+
 (define-public python-sphinx-pytest
   (package
     (name "python-sphinx-pytest")