diff mbox series

[bug#70855,82/92] gnu: python-pyan3: Move to pyproject-build-system.

Message ID 20240509225530.24649-82-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-pyan3):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Remove uneeded field.

Change-Id: I9f9f15ffd5a97666a410af56f02b573b55e45351
---
 gnu/packages/python-xyz.scm | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f145f19964c..61a517f72a6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34000,17 +34000,7 @@  (define-public python-pyan3
          "1367x25rcy2y8f0x9c2dbxl2qgdln3arr7ddyzybz2c28g6jrv5z"))
        (patches (search-patches "python-pyan3-fix-positional-arguments.patch"
                                 "python-pyan3-fix-absolute-path-bug.patch"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; Extend PYTHONPATH so the built package will be found.
-               (setenv "GUIX_PYTHONPATH"
-                       (string-append (getcwd) ":" (getenv "GUIX_PYTHONPATH")))
-               (invoke "pytest")))))))
+    (build-system pyproject-build-system)
     (native-inputs
      (list python-pytest python-pytest-cov python-wheel))
     (propagated-inputs