diff mbox series

[bug#70855,85/92] gnu: python-warcio: Move to pyproject-build-system.

Message ID 20240509225530.24649-85-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/python-web.scm (python-warcio):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Use <#:test-flags> instead of check phase replacement.

Change-Id: I7fd1ad51cddcbeb42c6aeeda552eb1a7bcd6e712
---
 gnu/packages/python-web.scm | 26 ++++++++++----------------
 1 file changed, 10 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index c24a3daa2e1..5f07b3cfc50 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6631,24 +6631,18 @@  (define-public python-warcio
          (sha256
           (base32
            "11afr6zy3r6rda81010iq496dazg4xid0izg3smg6ighpmvsnzf2"))))
-      (build-system python-build-system)
+      (build-system pyproject-build-system)
       (arguments
        (list
-        #:phases
-        #~(modify-phases %standard-phases
-            (replace 'check
-              (lambda* (#:key tests? #:allow-other-keys)
-                (when tests?
-                  (invoke "pytest" "-vv"
-                          ;; These tests fail due to networking requirements.
-                          "-k" (format #f "not ~a"
-                                       (string-join
-                                        '("test_post_chunked"
-                                          "test_remote"
-                                          "test_capture_http_proxy"
-                                          "test_capture_https_proxy"
-                                          "test_capture_https_proxy_same_session")
-                                        " and not ")))))))))
+        #:test-flags  ; These tests fail due to networking requirements.
+        '(list "-k" (format #f "not ~a"
+                            (string-join
+                             '("test_post_chunked"
+                               "test_remote"
+                               "test_capture_http_proxy"
+                               "test_capture_https_proxy"
+                               "test_capture_https_proxy_same_session")
+                             " and not ")))))
       (native-inputs
        ;; These inputs are required for the test suite.
        (list python-httpbin python-pytest-cov python-requests