diff mbox series

[bug#70855,72/92] gnu: python-uqbar: Improve package style.

Message ID 20240509225530.24649-72-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:54 p.m. UTC
* gnu/packages/graphviz.scm (python-uqbar): Improve package style.
  [build-system]: Move to pyproject-build-system.
  [arguments]: Convert 'check phase replacement to <#:test-flags>.

Change-Id: I536e60438e3f2d5592ab9cd34fe66104cfd117e2
---
 gnu/packages/graphviz.scm | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index fe67d103865..8ef3642e7e7 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -213,15 +213,9 @@  (define-public python-uqbar
         (base32
          "0c573nzpm51qgz2g296f8pw8ys0i3r6daynxk06zagk5l5fgw9ar"))
        (patches (search-patches "python-uqbar-python3.10.patch"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               (invoke "python" "-m" "pytest" "tests"))
-             #t)))))
+     (list #:test-flags '(list "tests")))
     (native-inputs
      (list graphviz
            python-flake8