diff mbox series

[bug#70855,55/92] gnu: python-jaraco-functools: Move to pyproject-build-system.

Message ID 20240509225530.24649-55-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/python-xyz.scm:
  (python-jaraco-functools-bootstrap)[build-system]: Move to
  pyproject-build-system.
  (python-jaraco-functools)[arguments]: Convert <#:phases> to
  <#:test-flags>.

Change-Id: Id41967b3cb426045877ceccd9b391d545d759560
---
 gnu/packages/python-xyz.scm | 18 ++++++------------
 1 file changed, 6 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 654224ee17e..93d2a5bb07b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11863,7 +11863,7 @@  (define-public python-jaraco-functools-bootstrap
         (uri (pypi-uri "jaraco.functools" version))
         (sha256
          (base32 "186xqzs3bqhjwajnprxy3sc3h0w5vdld8spc1dxjnn9720yykq1i"))))
-     (build-system python-build-system)
+     (build-system pyproject-build-system)
      (arguments (list #:tests? #f))
      (native-inputs (list python-setuptools-scm))
      (propagated-inputs (list python-more-itertools))
@@ -11881,17 +11881,11 @@  (define-public python-jaraco-functools
          (package-arguments python-jaraco-functools-bootstrap)
        ((#:tests? _ #f)
         (not (%current-target-system)))
-       ((#:phases phases #~%standard-phases)
-        #~(modify-phases #$phases
-            (replace 'check
-              (lambda* (#:key tests? #:allow-other-keys)
-                (when tests?
-                  ;; Do not test the myproject.toml build as it tries to pull
-                  ;; dependencies from the Internet.  Do not run a test that
-                  ;; tries to emulate a broken proprietary CI set-up, fails
-                  ;; to do so correctly, and then throws an error about it.
-                  (invoke "pytest" "-vv" "-k"
-                          "not project and not test_function_throttled"))))))))
+       ;; Do not test the myproject.toml build as it pulls dependencies.
+       ;; Do not run a test that tries to emulate a broken proprietary CI
+       ;; set-up, fails to do so correctly, and then throws an error.
+       ((#:test-flags test-flags '())
+        '(list "-k" "not project and not test_function_throttled"))))
     (native-inputs
      (modify-inputs
          (package-native-inputs python-jaraco-functools-bootstrap)