diff mbox series

[bug#70855,28/92] gnu: zulip-term: Move to pyproject-build-system.

Message ID 20240509225530.24649-28-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/messaging.scm (zulip-term):
  [build-system]: Move to pyproject-build-system.
  [arguments]<#:test-flags>: Use it in place of check phase replacement.

Change-Id: Ia5be66a35b92d9a9229f450a7724e27167c02eda
---
 gnu/packages/messaging.scm | 23 ++++++-----------------
 1 file changed, 6 insertions(+), 17 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 497808b069f..cb72bfb3e25 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3211,24 +3211,13 @@  (define-public zulip-term
         (base32
          "1xhhy3v4wck74a83avil0rnmsi2grrh03cww19n5mv80p2q1cjmf"))
        (modules '((guix build utils)))
-       (snippet
-        '(begin
-           (substitute* "setup.py"
-             (("\\=\\=1\\.7") ">=1.7")  ; pytest-mock
-             (("\\=\\=2\\.5") ">=2.5")  ; pytest-cov
-             (("4\\.5\\.2") "4.4.2"))   ; lxml
-           #t))))
-    (build-system python-build-system)
+       (snippet '(substitute* "setup.py"
+                   (("\\=\\=1\\.7") ">=1.7")    ; pytest-mock
+                   (("\\=\\=2\\.5") ">=2.5")    ; pytest-cov
+                   (("4\\.5\\.2") "4.4.2")))))  ; lxml
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; Delete failing tests.
-               (delete-file "tests/cli/test_run.py")
-               (invoke "pytest"))
-             #t)))))
+     '(#:test-flags '("--ignore=tests/cli/test_run.py")))
     (inputs
      (list python-beautifulsoup4
            python-lxml