diff mbox series

[bug#70855,58/92] gnu: python-nbstripout: Move to pyproject-build-system.

Message ID 20240509225530.24649-58-ngraves@ngraves.fr
State New
Headers show
Series python-team patches | expand

Commit Message

Nicolas Graves May 9, 2024, 10:53 p.m. UTC
* gnu/packages/jupyter.scm (python-nbstripout):
  [build-system]: Move to pyproject-build-system.
  [arguments]: Convert 'check replacement phase from <#:phases> to
  <#:test-flags>. Use gexp.

Change-Id: I4d97b0739c43371c149296b23951cb2c17129840
---
 gnu/packages/jupyter.scm | 26 ++++++++++++--------------
 1 file changed, 12 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 2c982b4c214..cf3fa509966 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -801,21 +801,19 @@  (define-public python-nbstripout
               (sha256
                (base32
                 "1n57nvxsc94gz9w8ymi83bjkfhfwkpmx4y14m6gjrmlqd49m1aw6"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'delete-bad-tests
-           (lambda _
-             ;; These tests use git and hg, and they are sensitive to the
-             ;; exact printed output.
-             (for-each delete-file (list "tests/test-git.t"
-                                         "tests/test-hg.t"
-                                         "tests/test-status.t"
-                                         "tests/test-uninstall.t"))))
-         (add-before 'check 'set-CRAMSHELL
-           (lambda _
-             (setenv "CRAMSHELL" (which "bash")))))))
+     (list
+      ;; These tests use git and hg, and they are sensitive to the
+      ;; exact printed output.
+      #:test-flags '(map (lambda (test)
+                           (string-append "--ignore=tests/test-" test ".t"))
+                         '("git" "hg" "status" "uninstall"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'set-CRAMSHELL
+            (lambda _
+              (setenv "CRAMSHELL" (which "bash")))))))
     (propagated-inputs (list python-nbformat))
     (native-inputs
      (list python-pytest