diff mbox series

[bug#42338,33/34] gnu: Add php-sebastian-code-unit.

Message ID 20200712222538.18092-33-julien@lepiller.eu
State New
Headers show
Series [bug#42338,01/34] guix: import: Add composer importer. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Julien Lepiller July 12, 2020, 10:25 p.m. UTC
* gnu/packages/php-xyz.scm (php-sebastian-code-unit): New variable.
---
 gnu/packages/php-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/php-xyz.scm b/gnu/packages/php-xyz.scm
index 484fb17790..0ae92c4600 100644
--- a/gnu/packages/php-xyz.scm
+++ b/gnu/packages/php-xyz.scm
@@ -768,3 +768,26 @@  of PHPUnit.  It provides a utility class for timing.")
 timeout.")
     (home-page "https://github.com/sebastianbergmann/php-invoker/")
     (license license:bsd-3)))
+
+(define-public php-sebastian-code-unit
+  (package
+    (name "php-sebastian-code-unit")
+    (version "1.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/sebastianbergmann/code-unit.git")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "058ykqcmzm900c513j2qvi189bgn0scxsrhbrik5xycrr620krxc"))))
+    (build-system composer-build-system)
+    (arguments
+     ;; We do not have phpunit yet
+     `(#:tests? #f))
+    (synopsis "PHP collection of value objects for code units")
+    (description "This package contains a collection of value objects that
+represent the PHP code units.")
+    (home-page "https://github.com/sebastianbergmann/code-unit")
+    (license license:bsd-3)))